jump to navigation

Melindungi Costumer dari Worm & Virus dengan Mikrotik December 28, 2009

Posted by ashril in Internet, Mikrotik, Networking.
add a comment

Untuk melindungi costumer’s network kita harus senantiasa mengecek semua traffic yang melewati router dan memblock traffic-traffic yang tidak diinginkan. Untuk traffic icmp, tcp, udp kita akan membuat chains, dimana semua paket traffic yang tidak diinginkan akan didrop. Sebagai langkah awal, kita dapat copy and paste command berikut pada RouterOS terminal console:

/ip firewall filter
add chain=forward connection-state=established comment=”allow established connections”
add chain=forward connection-state=related comment=”allow related connections”
add chain=forward connection-state=invalid action=drop comment=”drop invalid connections”

Disini pada 2 baris rule pertama mengatur bahwa router akan membolehkan koneksi yang telah terbuka (established connections) dan koneksi yang saling berhubungan (related connections), Kita membuat asumsi bahwa koneksi-koneksi tersebut adalah baik. Sedangkan koneksi yang mengandung invalid paket akan didrop, pada baris rule yang ke-3.

Kemudian, kita harus memfilter dan mendrop semua paket yang tidak diinginkan yang datang dari host yang dicurigai telah terinfeksi virus. Jadi setelah menambahkan rule-rule di atas ke forward chain, kita membuat sebuah chain baru untuk semua traffic netbios dan traffic serupa yang tidak diinginkan. Kita dapat memberikan sebuah deskriptif name (misalnya: “virus”) pada chain tersebut, saat menambahkan rule-rule berikut ini pada ip firewall filter (anda bisa mengcopy paste rule-rule ini kedalam RouterOS terminal console:

add chain=virus protocol=tcp dst-port=135-139 action=drop comment=”Drop Blaster Worm”
add chain=virus protocol=udp dst-port=135-139 action=drop comment=”Drop Messenger Worm”
add chain=virus protocol=tcp dst-port=445 action=drop comment=”Drop Blaster Worm”
add chain=virus protocol=udp dst-port=445 action=drop comment=”Drop Blaster Worm”
add chain=virus protocol=tcp dst-port=593 action=drop comment=”________”
add chain=virus protocol=tcp dst-port=1024-1030 action=drop comment=”________”
add chain=virus protocol=tcp dst-port=1080 action=drop comment=”Drop MyDoom”
add chain=virus protocol=tcp dst-port=1214 action=drop comment=”________”
add chain=virus protocol=tcp dst-port=1363 action=drop comment=”ndm requester”
add chain=virus protocol=tcp dst-port=1364 action=drop comment=”ndm server”
add chain=virus protocol=tcp dst-port=1368 action=drop comment=”screen cast”
add chain=virus protocol=tcp dst-port=1373 action=drop comment=”hromgrafx”
add chain=virus protocol=tcp dst-port=1377 action=drop comment=”cichlid”
add chain=virus protocol=tcp dst-port=1433-1434 action=drop comment=”Worm”
add chain=virus protocol=tcp dst-port=2745 action=drop comment=”Bagle Virus”
add chain=virus protocol=tcp dst-port=2283 action=drop comment=”Drop Dumaru.Y”
add chain=virus protocol=tcp dst-port=2535 action=drop comment=”Drop Beagle”
add chain=virus protocol=tcp dst-port=2745 action=drop comment=”Drop Beagle.C-K”
add chain=virus protocol=tcp dst-port=3127-3128 action=drop comment=”Drop MyDoom”
add chain=virus protocol=tcp dst-port=3410 action=drop comment=”Drop Backdoor OptixPro”
add chain=virus protocol=tcp dst-port=4444 action=drop comment=”Worm”
add chain=virus protocol=udp dst-port=4444 action=drop comment=”Worm”
add chain=virus protocol=tcp dst-port=5554 action=drop comment=”Drop Sasser”
add chain=virus protocol=tcp dst-port=8866 action=drop comment=”Drop Beagle.B”
add chain=virus protocol=tcp dst-port=9898 action=drop comment=”Drop Dabber.A-B”
add chain=virus protocol=tcp dst-port=10000 action=drop comment=”Drop Dumaru.Y”
add chain=virus protocol=tcp dst-port=10080 action=drop comment=”Drop MyDoom.B”
add chain=virus protocol=tcp dst-port=12345 action=drop comment=”Drop NetBus”
add chain=virus protocol=tcp dst-port=17300 action=drop comment=”Drop Kuang2″
add chain=virus protocol=tcp dst-port=27374 action=drop comment=”Drop SubSeven”
add chain=virus protocol=tcp dst-port=65506 action=drop comment=”Drop PhatBot, Agobot, Gaobot”

Disini, kita melist semua yang kita ketahui sebagai “bad” protocol and port, yang digunakan oleh beragam trojans dan virus. List ini masih belum lengkap; kita masih harus terus menambahkan rule-rule ke dalamnya. Kita dapat melompat ke list ini dari forward chain dengan menambahkan rule dengan action=jump:

add chain=forward action=jump jump-target=virus comment=”jump to the virus chain”

Forward chain akan nampak seperti berikut ini

Sehingga nampak bisa dilihat pada gambar, apabila paket atau koneksi yang berjalan tidak sesuai dengan rule chain=virus maka segera diproses kembali ke chain=forward;

Selamat mencoba…

Queue dengan SRC-NAT dan WEB-PROXY March 2, 2008

Posted by ashril in Mikrotik, Networking.
2 comments

Pada penggunaan queue (bandwidth limiter), penentuan CHAIN pada MENGLE sangat menentukan jalannya sebuah rule. Jika kita memasang SRC-NAT dan WEB-PROXY pada mesin yang sama, sering kali agak sulit untuk membuat rule QUEUE yang sempurna. Penjelasan detail mengenai pemilihan CHAIN, dapat dilihat pada manual Mikrotik di sini.

Percobaan yang dilakukan menggunakan sebuah PC dengan Mikrotik RouterOS versi 2.9.28. Pada mesin tersebut, digunakan 2 buah interface, satu untuk gateway yang dinamai PUBLIC dan satu lagi untuk jaringan lokal yang dinamai LAN.

(more…)

Firewall untuk router mikrotik March 2, 2008

Posted by ashril in Mikrotik, Networking.
2 comments

Untuk mengamankan router mikrotik dari traffic virus dan excess ping dapat digunakan skrip firewall berikutPertama buat address-list “ournetwork” yang berisi alamat IP radio,  IP LAN dan IP WAN atau IP lainnya yang dapat dipercaya

Dalam contoh berikut alamat IP radio adalah = 10.0.0.0/16, IP LAN = 192.168.2.0/24 dan IP WAN = 203.89.24.0/21 dan IP lainnya yang dapat dipercaya = 202.67.33.7

Untuk membuat address-list dapat menggunakan contoh skrip seperti berikut ini tinggal disesuaikan dengan konfigurasi jaringan Anda.

Buat skrip berikut menggunakan notepad kemudian copy-paste ke console mikrotik

/ ip firewall address-list
add list=ournetwork address=203.89.24.0/21 comment=”Datautama Network”
disabled=no
add list=ournetwork address=10.0.0.0/16 comment=”IP Radio” disabled=no
add list=ournetwork address=192.168.2.0/24 comment=”LAN Network” disabled=no

(more…)

Simple Queue, Memisah Bandwidth Lokal dan Internasional February 28, 2008

Posted by ashril in Internet, Mikrotik, Networking.
1 comment so far

dari: Mikrotik Indonesia
Selama mengelola Mikrotik Indonesia, banyak sekali muncul pertanyaan bagaimana cara melakukan pemisahan queue untuk trafik internet internasional dan trafik ke internet Indonesia (OpenIXP dan IIX). Di internet sebetulnya sudah ada beberapa website yang menampilkan cara pemisahan ini, tapi kami akan coba menampilkan kembali sesederhana mungkin supaya mudah diikuti.

Pada artikel ini, kami mengasumsikan bahwa:

  1. Router Mikrotik melakukan Masquerading / src-nat untuk client. Client menggunakan IP privat.
  2. Gateway yang digunakan hanya satu, baik untuk trafik internasional maupun IIX.
  3. Anda bisa menggunakan web-proxy internal ataupun tanpa web-proxy. Jika Anda menggunakan web-proxy, maka ada beberapa tambahan rule yang perlu dilakukan. Perhatikan bagian NAT dan MANGLE pada contoh di bawah ini.

Jika ada parameter di atas yang berbeda dengan kondisi Anda di lapangan, maka konfigurasi yang ada di artikel ini harus Anda modifikasi sesuai dengan konfigurasi network Anda.

(more…)

Memperkecil delay ping dan DNS resolve February 28, 2008

Posted by ashril in Mikrotik, Networking.
10 comments

Tujuan :

  • Memperkecil delay ping dari sisi klien ke arah Internet.
  • Mempercepat resolving hostname ke ip address.

(more…)

Membagi Bandwidth dengan PCQ di Mikrotik February 28, 2008

Posted by ashril in Mikrotik, Networking.
14 comments

Dengan menggunakan queue type pcq di Mikrotik, kita bisa membagi bandwidth yang ada secara merata untuk para “pelahap-bandwidth” saat jaringan pada posisi peak.

Contohnya, kita berlangganan 256 Kbps. Kalau ada yang sedang berinternet ria, maka beliau dapat semua itu jatah bandwidth. Tetapi begitu teman-temannya datang, katakanlah 9 orang lagi, maka masing-masingnya dapat sekitar 256/10 Kbps.

Yah.. masih cukup layaklah untuk buka-buka situs non-porn atau sekedar cek e-mail & blog.

  (more…)

Load Balancing & Fail-Over di Mikrotik February 28, 2008

Posted by ashril in Mikrotik, Networking.
add a comment

Kondisi : ISP dimana kita bekerja sebagai Administrator menggunakan lebih dari satu gateway untuk terhubung ke Internet. Semuanya harus dapat melayani layanan upstream & downstream. Karena akan beda kasusnya apabila salah satunya hanya dapat melayani downstream, contohnya jika menggunakan VSAT DVB One-way.

Untuk kasus ini dimisalkan ISP memiliki 2 jalur ke Internet. Satu menggunakan akses DSL (256 Kbps) dan lainnya menggunakan Wireless (512 Kbps). Dengan rasio pemakaian DSL:Wireless = 1:2 .

  (more…)

nulis lagi.. February 28, 2008

Posted by ashril in Catatankoe...
add a comment

sorry karena kesibukan dll.. baru smpet mulai nulis lagii

dah lama banget ya..

tujuan.. September 3, 2007

Posted by ashril in Catatankoe...
add a comment

tujuan.. menyempitkan ruang langkah, membangun dinding pembenaran, memperbesar keakuan..

aku..

bossen::

ndaftar user situs web mikrotik indonesia August 30, 2007

Posted by ashril in Catatankoe...
2 comments

barusan aku ndaftar user di situs web mikrotik indonesia (www.mikrotik.co.id)
busyett profile yang aku isiin dikonfirm via telpon man.. mantabb kalii..
hehe..